This project has moved and is read-only. For the latest updates, please go here.

I can't seem to get it working

Feb 3, 2015 at 6:31 PM
Downloaded this tool from NuGet (
I updated the DatabaseDeploy.exe.config to point to the locally deployed Sql Server Express 2012
I run "DatabaseDeploy.exe" from the command prompt
The command failed with a long exception & stack trace
I create the database manually, run the same command and this time no exception (I was hoping the tool would create the db automatically if it was missing).
The only thing that the command did was to create the changelog table, this table is empty
I tried to use the tool to create the Foo table that comes with the binaries, but it does not seem to work, this is the output from the log file:

2015-02-03 18:14:13,353 [1] INFO Veracity.Utilities.DatabaseDeploy.DeploymentService (null) - Cleaning up past runs.
2015-02-03 18:14:13,360 [1] INFO Veracity.Utilities.DatabaseDeploy.DeploymentService (null) - Getting available script files.
2015-02-03 18:14:13,370 [1] INFO Veracity.Utilities.DatabaseDeploy.DeploymentService (null) - Writing found file list into C:\Code_M\DbDeploy2Sample\DbDeploy2Sample\dbdeploy.\Schema\ScriptList.txt
2015-02-03 18:14:13,393 [1] INFO Veracity.Utilities.DatabaseDeploy.DeploymentService (null) - Found scripts 1. Getting applied changes.
2015-02-03 18:14:13,553 [1] INFO Veracity.Utilities.DatabaseDeploy.DeploymentService (null) - Found scripts No scripts found.. Getting scripts to apply.
2015-02-03 18:14:13,568 [1] INFO Veracity.Utilities.DatabaseDeploy.DeploymentService (null) - Scripts 1 need to be applied. Building change script.
2015-02-03 18:14:13,584 [1] INFO Veracity.Utilities.DatabaseDeploy.DeploymentService (null) - Building undo script for scripts No scripts found..
2015-02-03 18:14:13,594 [1] INFO Veracity.Utilities.DatabaseDeploy.DeploymentService (null) - Writing change script to ..\ProductionUpdate.sql
2015-02-03 18:14:13,602 [1] INFO Veracity.Utilities.DatabaseDeploy.DeploymentService (null) - Writing undo change script to DbDeployUndo.sql
2015-02-03 18:14:13,611 [1] INFO Veracity.Utilities.DatabaseDeploy.DeploymentService (null) - Deployment generation complete.

Am I missing something?
Feb 3, 2015 at 6:32 PM
I should add that the ScriptList.txt file is created and it lists the script I wanted the tool to run, i.e.:

This file is autogenerated and will be replaced on each run of DatabaseDeploy. You should not change the contents.
This file reflects all of the scripts that were found in this directory and if recursion is on, child directories. These are the scripts that will be included in the deployment script.

The order in which the scripts will be applied is the order in which they appear in this file.

C:\Code_M\DbDeploy2Sample\DbDeploy2Sample\dbdeploy\Schema\0001 Create Foo Table.sql
May 3, 2015 at 6:42 AM
Edited May 3, 2015 at 6:42 AM
I ran into the same problem.
Have you found solution to this?

I am using command line to execute DbDeploy
May 6, 2015 at 9:31 AM
I switched to using Liquibase for now, seems to be a more active project with a more sophisticated approach to db refactorings.
Aug 24, 2015 at 5:48 PM
Sorry for the delayed response. I've been really busy with work. I'll see if I can't make this a little more clear and improve the nugget package installation.
Aug 24, 2015 at 5:49 PM
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.
Aug 25, 2015 at 2:07 AM

I've updated the nugget package and added step by step instructions. I've also tested and as long as you follow those instructions, you should be good.

I think that the MSBuild task was confusing people, so I've made that a little less visible. Hopefully, this will help people understand.